#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]"
Local $sString = "[[NOTE]]This is my note.[[NOTE]]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)