const regex = /\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[NOTE]]((?:(?!\\[\\[NOTE\\]\\]).)*)\\[\\[NOTE]]', 'gm')
const str = `[[NOTE]]This is my note.[[NOTE]]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);