using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]";
string substitution = @"";
string input = @"[[NOTE]]This is my note.[[NOTE]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}