use strict;
my $str = '[[NOTE]]This is my note.[[NOTE]]';
my $regex = qr/\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";