import re
regex = re.compile(r"\[\[NOTE]]((?:(?!\[\[NOTE\]\]).)*)\[\[NOTE]]", flags=re.MULTILINE)
test_str = "[[NOTE]]This is my note.[[NOTE]]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)