#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:0|\+33)(?:6|7))\d{8}$"
Local $sString = "0611223344" & @CRLF & _
"0744332211" & @CRLF & _
"+33611223344" & @CRLF & _
"+33744332211" & @CRLF & _
"06112233440744332211" & @CRLF & _
"+33611223344+33611223344" & @CRLF & _
"0611223344 0744332211" & @CRLF & _
"0744332211+33611223344" & @CRLF & _
"0744332211 +33611223344"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")