const regex = /^(?:(?:0|\+33)(?:6|7))\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:0|\\+33)(?:6|7))\\d{8}$', 'gm')
const str = `0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}