use strict;
my $str = '0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344';
my $regex = qr/^(?:(?:0|\+33)(?:6|7))\d{8}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}