import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:0|\\+33)(?:6|7))\\d{8}$";
final String string = "0611223344\n"
+ "0744332211\n"
+ "+33611223344\n"
+ "+33744332211\n"
+ "06112233440744332211\n"
+ "+33611223344+33611223344\n"
+ "0611223344 0744332211\n"
+ "0744332211+33611223344\n"
+ "0744332211 +33611223344";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}