package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:0|\+33)(?:6|7))\d{8}$`)
var str = `0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}