$re = '/^(?:(?:0|\+33)(?:6|7))\d{8}$/m';
$str = '0611223344
0744332211
+33611223344
+33744332211
06112233440744332211
+33611223344+33611223344
0611223344 0744332211
0744332211+33611223344
0744332211 +33611223344';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);