import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9a-z-A-Z]+){1}+((\\s+[a-zA-Z.,]+|\\s+[a-zA-Z,.]+\\s){2,10})?(\\#[0-9a-z-\\-]+|\\#\\s+[0-9\\-]+|[0-9\\-]+))";
final String string = "3724 South Laurelcrest Street Salt Lake City,\n"
+ "3724 S Laurelcrest St \n"
+ "Salt Lake City, UT 84109-3757\n"
+ "thisis a \n"
+ "7850 S Dean Martin Dr Suite 505\n\n"
+ "4590-3- test concealesd siote 404\n\n"
+ "747 Sheridan Blvd, #3a, Lakewood, CO 80214";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}