use strict;
my $str = '3724 South Laurelcrest Street Salt Lake City,
3724 S Laurelcrest St
Salt Lake City, UT 84109-3757
thisis a
7850 S Dean Martin Dr Suite 505
4590-3- test concealesd siote 404
747 Sheridan Blvd, #3a, Lakewood, CO 80214';
my $regex = qr/(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}