// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))").unwrap();
let string = "3724 South Laurelcrest Street Salt Lake City,
3724 S Laurelcrest St
Salt Lake City, UT 84109-3757
thisis a
7850 S Dean Martin Dr Suite 505
4590-3- test concealesd siote 404
747 Sheridan Blvd, #3a, Lakewood, CO 80214";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}