import Foundation
let pattern = ##"(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
3724 South Laurelcrest Street Salt Lake City,
3724 S Laurelcrest St
Salt Lake City, UT 84109-3757
thisis a
7850 S Dean Martin Dr Suite 505
4590-3- test concealesd siote 404
747 Sheridan Blvd, #3a, Lakewood, CO 80214
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)