import re
regex = re.compile(r"(([0-9a-z-A-Z]+){1}+((\s+[a-zA-Z.,]+|\s+[a-zA-Z,.]+\s){2,10})?(\#[0-9a-z-\-]+|\#\s+[0-9\-]+|[0-9\-]+))")
test_str = ("3724 South Laurelcrest Street Salt Lake City,\n"
"3724 S Laurelcrest St \n"
"Salt Lake City, UT 84109-3757\n"
"thisis a \n"
"7850 S Dean Martin Dr Suite 505\n\n"
"4590-3- test concealesd siote 404\n\n"
"747 Sheridan Blvd, #3a, Lakewood, CO 80214")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")