#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<input\s+name="data\[Product\]\[name\]"\s+value="([^"]+)""
Local $sString = "<input name="data[Product][name]" value="Бумага SvetoCopy Ð4 80г/м 500л." type="hidden">" & @CRLF & _
"<input name="data[Product][name]" value="Бумага SvetoCopy Ð3 80г/м 500л." type="hidden">" & @CRLF & _
"<input name="data[Product][name]" value="Бумага Снегурочка Ð4 80г/м 500л." type="hidden">" & @CRLF & _
"<input name="data[Product][name]" value="Ручка гел. Ñин 05 ЕК8791" type="hidden">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")