using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input\s+name=""data\[Product\]\[name\]""\s+value=""([^""]+)""";
string input = @"<input name=""data[Product][name]"" value=""Бумага SvetoCopy Ð4 80г/м 500л."" type=""hidden"">
<input name=""data[Product][name]"" value=""Бумага SvetoCopy Ð3 80г/м 500л."" type=""hidden"">
<input name=""data[Product][name]"" value=""Бумага Снегурочка Ð4 80г/м 500л."" type=""hidden"">
<input name=""data[Product][name]"" value=""Ручка гел. Ñин 05 ЕК8791"" type=""hidden"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}