// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input\s+name="data\[Product\]\[name\]"\s+value="([^"]+)""#).unwrap();
let string = "<input name=\"data[Product][name]\" value=\"Бумага SvetoCopy Ð4 80г/м 500л.\" type=\"hidden\">
<input name=\"data[Product][name]\" value=\"Бумага SvetoCopy Ð3 80г/м 500л.\" type=\"hidden\">
<input name=\"data[Product][name]\" value=\"Бумага Снегурочка Ð4 80г/м 500л.\" type=\"hidden\">
<input name=\"data[Product][name]\" value=\"Ручка гел. Ñин 05 ЕК8791\" type=\"hidden\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}