const regex = /<input\s+name="data\[Product\]\[name\]"\s+value="([^"]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input\\s+name="data\\[Product\\]\\[name\\]"\\s+value="([^"]+)"', 'g')
const str = `<input name="data[Product][name]" value="Бумага SvetoCopy Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага SvetoCopy Ð3 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага Снегурочка Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Ручка гел. Ñин 05 ЕК8791" type="hidden">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}