re = /<input\s+name="data\[Product\]\[name\]"\s+value="([^"]+)"/
str = '<input name="data[Product][name]" value="Бумага SvetoCopy Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага SvetoCopy Ð3 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага Снегурочка Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Ручка гел. Ñин 05 ЕК8791" type="hidden">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end