package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input\s+name="data\[Product\]\[name\]"\s+value="([^"]+)"`)
var str = `<input name="data[Product][name]" value="Бумага SvetoCopy Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага SvetoCopy Ð3 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Бумага Снегурочка Ð4 80г/м 500л." type="hidden">
<input name="data[Product][name]" value="Ручка гел. Ñин 05 ЕК8791" type="hidden">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}