# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a\s+[^>]*?href="[^"]*#!(\[.*?\])"[^>]*?>[^<>]*?<span[^>]*?>[^<>]*?<\\/span>[^<>]*?<\\/a>)/$1 <a href="http:\/\/no.refer.co\/?link=https:\/\/mega.co.nz\/%23!$2" target="_blank">NoRefer<\/a>/g;t' <<< "<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a>
needed:
<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a> <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23![RandomThings1]\" target=\"_blank\">NoRefer</a>"