// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a\s+[^>]*?href="[^"]*#!(\[.*?\])"[^>]*?>[^<>]*?<span[^>]*?>[^<>]*?<\/span>[^<>]*?<\/a>)"#).unwrap();
let string = "<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a>
needed:
<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a> <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23![RandomThings1]\" target=\"_blank\">NoRefer</a>";
let substitution = "$1 <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23!$2\" target=\"_blank\">NoRefer</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}