import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a\\s+[^>]*?href=\"[^\"]*#!(\\[.*?\\])\"[^>]*?>[^<>]*?<span[^>]*?>[^<>]*?<\\/span>[^<>]*?<\\/a>)";
final String string = "<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a>\n\n"
+ "needed:\n"
+ "<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a> <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23![RandomThings1]\" target=\"_blank\">NoRefer</a>";
final String subst = "$1 <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23!$2\" target=\"_blank\">NoRefer</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}