# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a\s+[^>]*?href=\"[^\"]*#!(\[.*?\])\"[^>]*?>[^<>]*?<span[^>]*?>[^<>]*?<\/span>[^<>]*?<\/a>)"
test_str = ("<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a>\n\n"
"needed:\n"
"<a href=\"https://mega.co.nz/#![RandomThings1]\" target=\"_blank\">[RandomThings2] [<span style=\"color:#008000;\">[RandomThings3]</span>]</a> <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23![RandomThings1]\" target=\"_blank\">NoRefer</a>")
subst = "$1 <a href=\"http://no.refer.co/?link=https://mega.co.nz/%23!$2\" target=\"_blank\">NoRefer</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.