using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a\s+[^>]*?href=""[^""]*#!(\[.*?\])""[^>]*?>[^<>]*?<span[^>]*?>[^<>]*?<\/span>[^<>]*?<\/a>)";
string substitution = @"$1 <a href=""http://no.refer.co/?link=https://mega.co.nz/%23!$2"" target=""_blank"">NoRefer</a>";
string input = @"<a href=""https://mega.co.nz/#![RandomThings1]"" target=""_blank"">[RandomThings2] [<span style=""color:#008000;"">[RandomThings3]</span>]</a>
needed:
<a href=""https://mega.co.nz/#![RandomThings1]"" target=""_blank"">[RandomThings2] [<span style=""color:#008000;"">[RandomThings3]</span>]</a> <a href=""http://no.refer.co/?link=https://mega.co.nz/%23![RandomThings1]"" target=""_blank"">NoRefer</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}