#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[v]((\d?\d\.)(0\.|[1-9]?[0-9]\.)([1-9]?[0-9]|))$"
Local $sString = "v0.1.2" & @CRLF & _
"v12.1.0" & @CRLF & _
"v0.0.1" & @CRLF & _
"v0.12.0" & @CRLF & _
"v10.10.10" & @CRLF & _
"10.10.10" & @CRLF & _
"v222.10.0" & @CRLF & _
"v0.999.0" & @CRLF & _
"v0.1.111" & @CRLF & _
"v0.01.0" & @CRLF & _
"v0.1.01" & @CRLF & _
"v12.1" & @CRLF & _
"v12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")