const regex = /^[v]((\d?\d\.)(0\.|[1-9]?[0-9]\.)([1-9]?[0-9]|))$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[v]((\\d?\\d\\.)(0\\.|[1-9]?[0-9]\\.)([1-9]?[0-9]|))$', 'mg')
const str = `v0.1.2
v12.1.0
v0.0.1
v0.12.0
v10.10.10
10.10.10
v222.10.0
v0.999.0
v0.1.111
v0.01.0
v0.1.01
v12.1
v12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}