using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[v]((\d?\d\.)(0\.|[1-9]?[0-9]\.)([1-9]?[0-9]|))$";
string input = @"v0.1.2
v12.1.0
v0.0.1
v0.12.0
v10.10.10
10.10.10
v222.10.0
v0.999.0
v0.1.111
v0.01.0
v0.1.01
v12.1
v12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}