$re = '/^[v]((\d?\d\.)(0\.|[1-9]?[0-9]\.)([1-9]?[0-9]|))$/m';
$str = 'v0.1.2
v12.1.0
v0.0.1
v0.12.0
v10.10.10
10.10.10
v222.10.0
v0.999.0
v0.1.111
v0.01.0
v0.1.01
v12.1
v12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);