import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[v]((\\d?\\d\\.)(0\\.|[1-9]?[0-9]\\.)([1-9]?[0-9]|))$";
final String string = "v0.1.2\n"
+ "v12.1.0\n"
+ "v0.0.1\n"
+ "v0.12.0\n"
+ "v10.10.10\n"
+ "10.10.10\n"
+ "v222.10.0\n"
+ "v0.999.0\n"
+ "v0.1.111\n"
+ "v0.01.0\n"
+ "v0.1.01\n"
+ "v12.1\n"
+ "v12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}