// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[v]((\d?\d\.)(0\.|[1-9]?[0-9]\.)([1-9]?[0-9]|))$").unwrap();
let string = "v0.1.2
v12.1.0
v0.0.1
v0.12.0
v10.10.10
10.10.10
v222.10.0
v0.999.0
v0.1.111
v0.01.0
v0.1.01
v12.1
v12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}