# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\/([^_]+).*/$1/gm;t' <<< "c://abcd /abcdef/0012wetr_1234567890.csv"