package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*/([^_]+).*`)
var str = `c://abcd /abcdef/0012wetr_1234567890.csv`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}