re = /.*\/([^_]+).*/m
str = 'c://abcd /abcdef/0012wetr_1234567890.csv'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result