using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/([^_]+).*";
string substitution = @"$1";
string input = @"c://abcd /abcdef/0012wetr_1234567890.csv";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}