const regex = new RegExp('.*/([^_]+).*', 'gm')
const str = `c://abcd /abcdef/0012wetr_1234567890.csv`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);