# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\w+\b\\//...\//g;t' <<< "p := some/path/to/file"