import Foundation
let pattern = #"\b\w+\b\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"p := some/path/to/file"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".../"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)