# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[\w_\-]+\b\\//...\//g;t' <<< "p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file"