import Foundation
let pattern = #"\b[\w_\-]+\b\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".../"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)