$re = '/\b[\w_\-]+\b\//';
$str = 'p := some/path/to/file
p := so_me/pa-th/to/file
p := so_me/mo-re/pat_hs/to_your/file';
$subst = ".../";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;