#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b[\w_\-]+\b\/"
Local $sString = "p := some/path/to/file" & @CRLF & _
"p := so_me/pa-th/to/file" & @CRLF & _
"p := so_me/mo-re/pat_hs/to_your/file"
Local $sSubst = ".../"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)