# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])/\\\1/gi;t' <<< "Foo (.* ) bar blla (.* ) b*l?a$ && bla bla "