using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])";
string substitution = @"\\\1";
string input = @"Foo (.* ) bar blla (.* ) b*l?a$ && bla bla ";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}