$re = '~\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])~i';
$str = 'Foo (.* ) bar blla (.* ) b*l?a$ && bla bla ';
$subst = "\\\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;