const regex = new RegExp('\\([^)]*\\)(*SKIP)(*FAIL)|([^a-z\\d ])', 'gi')
const str = `Foo (.* ) bar blla (.* ) b*l?a\$ && bla bla `;
const subst = `\\\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);