import re
regex = re.compile(r"\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])", flags=re.IGNORECASE)
test_str = "Foo (.* ) bar blla (.* ) b*l?a$ && bla bla "
subst = "\\\\\\1"
result = regex.sub(subst, test_str)
if result:
print(result)