#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\([^)]*\)(*SKIP)(*FAIL)|([^a-z\d ])"
Local $sString = "Foo (.* ) bar blla (.* ) b*l?a$ && bla bla "
Local $sSubst = "\\\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)